Thursday, July 26, 2007

Building Epiphany with the WebKit backend

I recently built Epiphany with the experimental WebKit backend as per Xan's instructions here. These are few notes that might be helpful to others:
- Once you get the patch, apply it with this command in the Ephy source directory:
patch -p1 < ephy-webkit.patch
- Make sure you have the pre-requisite packages before you build WebKit. This page is a good reference on building WebKit with Gdk. Refer to this page for common build errors.
- Test your WebKit build by running the simple test browser: WebKit/WebKitBuild/Debug/WebKitTools/GdkLauncher/GdkLauncher
- To build Epiphany from svn, you will need GLib-2 2.13.4 or higher and GTK+-2 2.11.6 or higher. You can get them using JHBuild:
jhbuild buildone glib gtk+

2 comments:

Marius said...

For some reason the less-than sign disappeared in your RSS feed leaving an incorrect patch command.

Alternatively you could say patch -p1 -i ephy-webkit.patch

isb said...

Thanks Marius,

Not sure why RSS ate the < sign.